HOWTO install Oanda Desktop (fxTrade) on Ubuntu 18.04 LTS or Debain

FTMO Trader Scouting


Staff member
This HOWTO is for installing Oanda Desktop / fxTrade on the latest Ubuntu 18.04 LTS and Debian.

Previously, you could launch Oanda's fxTrade directly from your browser in Linux so long as you had the right Java version and browser plugin installed. However, Oanda created a new web based trading platform and only offers fxTrade for desktop use. Many long running Oanda clients will prefer the fxTrade environment, so here's how to get fxTrade working on your Ubuntu or Debian Linux OS.

First up, we will need to install a compatible version of Java. In the past when we wanted to run fxTrade directly from a browser plugin, we would use Oracle's Java. Oracle however, has gone full commercial with their Java implementation, and since we no longer need the browser plugin I'm going to suggest using the default OpenJDK Java implementation that comes with Debian/Ubuntu:

All we have to do is enter the following commands in a terminal window to install OpenJDK: (To open a terminal window in Ubuntu's Unity desktop or Debian while using Gnome desktop, just do the key combination: CTRL+ALT+T)
sudo apt-get update
sudo apt install default-jre
(Hit enter when asked to install the required new packages after that last command.)

Once complete, grab the latest install for Oanda Desktop (fxTrade) from their site. You don't need to be logged in to get the install files, but you do need to access these links from the machine you're installing Oanda Desktop on as it uses your browser's client data to know what platfrom you wish to use (that is to say, if you follow these links on a Windows machine, you're going to get Windows installer files.. so use your Linux computer to get the Linux install script.)

Oanda Desktop:
Oanda Practice Desktop:

This should prompt you to download a .tar archive file. Save this file in your downloads folder.

Next we want to extract the contents of the .tar file we just downloaded. Since we will be executing the installer in a terminal / command line interface, let's use the terminal to extract the archive:

cd Downloads/
tar -xvvf fxTradePractice_installer.tar

Notes on the above:
  • If you've saved the installer to another directory, you will have to 'cd' into that directory.
  • If you're using the live client, the filename will be different and not include the word "Practice", adjust this line accordingly.
Finally, run the installer script:

This should only take a second. Once complete, you will see a new icon on your desktop for the installed fxTrade application.

Ubuntu may not know the application and might need to confirm with you that it can be trusted:

And upon running for the first time, it may take a moment as the application grabs the latest files from Oanda's servers. Once it's done, you should be greeted with Oanda Desktop (fxTrade) asking you to login:

I think I need some help here. I followed the process but I wasnt able to lunch the desktop application. This is the message I am seeing:

Name=fxTrade Practice
Exec=java -jar -Xmx512m -Dsun.java2d.d3d=false /home/xxx/.oanda/jar/fxTradePractice/fxTradePractice

Any idea where I am failing?
Are you on 18.04 LTS with the Unity desktop?

Sounds like when you double click the shortcut you're opening the shortcut in a text editor instead of having it launch the application.

If you open a terminal window, you can execute it yourself by copying and pasting the line in your post after "Exec="
I am using ubuntu 20.4 in Norwegian languange.
In non-english versions desktop the isntallation folder has a different name, so I have tried to modify the file an editor and change the references but that was unsuccessfull.

I thought about changing the ubuntu language before installation, but that will change just the menu and not the folders.

So..... then I have tried to fire up the ubuntu in english version in vmware for testing.
I have followed the procedure but it does not seem to create an icon on desktop which i can lunch
Oanda Fxtrade setup for Ubuntu: 20.04 LTS 64-bit

Gnome Version: 3.36.8

Windowning System: X11

Files needed​

Oanda FxTrade Desktop for PC (their page will direct download to OS type)

Java SE Runtime Environment 8u171

Java SE Development Kit 8u171

files are in archive of oracle you will need to create an account to download each file or hunt the web for a different way


JRE Setup​

sudo mkdir /usr/local/java
sudo mv jre-8u171-linux-x64.tar.gz /usr/local/java
cd /usr/local/java
sudo tar zxvf jre-8u171-linux-x64.tar.gz
sudo update-alternatives --install "/usr/bin/java" "java" "/usr/local/java/jre1.8.0_171/bin/java" 1
java -version

It should output the following:

java version "1.8.0_171"
Java(TM) SE Runtime Environment (build 1.8.0_171-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.171-b11, mixed mode)

JDK Setup​
sudo mkdir /usr/lib/jvm
cd /usr/lib/jvm
sudo tar -xzvf ~/Downloads/jdk-8u171-linux-x64.tar.gz
sudo gedit /etc/environment

so in this file you will see the type line starting with PATH=

and then enter into the statement with the first quote, and at the end of the statement it exits with a quote mark as well... between each addition is a : mark
so place your mouse curser after the last comment and before the exit quote to add our statement


verify that the quote got pushed to the end of line 2 and should appear after the bin

if your good then continue




These should end up as their own lines , verify the java versions match what you installed, and save file

you may get some errors on the terminal readout , there was a issue and even a switch -H that could be used in gedit command that might help, that i did not, but i have not seen any issues within the operation of fxtrade to worry about this. Below is what my file looks like, all systems are different and yours may have an additional line, or extra input of some sort, prior to editing i would look at what is there first.




J2REDIR="/usr/lib/jvm/jdk1.8.0_171/jre" JAVA_HOME="/usr/lib/jvm/jdk1.8.0_171"


then back in terminal the following:

sudo update-alternatives --install "/usr/bin/java" "java" "/usr/lib/jvm/jdk1.8.0_261/bin/java" 0

sudo update-alternatives --install "/usr/bin/javac" "javac" "/usr/lib/jvm/jdk1.8.0_261/bin/javac" 0

sudo update-alternatives --set java /usr/lib/jvm/jdk1.8.0_261/bin/java

sudo update-alternatives --set javac /usr/lib/jvm/jdk1.8.0_261/bin/javac

like above in the JRE setup we are going to check out our work

update-alternatives --list java

update-alternatives --list javac

--list name
Display all targets of the link group.


Download the current fxtrade_installer.tar from Oanda

enter terminal

cd Downloads

tar -xvvf fxTrade_installer.tar


you should have an icon appear on the desktop now, from there right click on the icon to get the side menu and click "Allow Launching"

then go ahead and launch fxtrade , if you get the older square login we had then the java and so on is not setup correctly somehow, and that will have errors updating pricing and keeping the quotes active ,you should get the new login popup.

below is the old login popup:

old login.png

below is the new login popup:

Screenshot from 2022-04-14 11-17-19.png
General Notes about my install

I did not use the current version of the JRE and JDK for this computer because at the time i had one netbook that could run linux and the fxtrade desktop and was manually cloaning that setup to the new computer with an updated Ubuntu version and the new hardware.

I did not spend the time to walk the java versions up from 171 to see where fxtrade broke

the problem i had been having on previous installs was that the price quote on the left and the ones seen in the chart did not match, so my left view woud say audusd say 67/69 and the chart might be all the way up to 71/73

that said the closing of trades was fine, any profit or loss was as the chart showed

the other problem i notice was the bottom left hand corner Green/yellow connection bar was empty or greyed out before i did this method

I installed JRE first checked it and then Installed JDK, then i installed the Oanda fxtrade Desktop

there may have been overlap in what was being installed on the java side, but i noticed that not installing the jdk, fxtrade was still broke - it would load, update and so on , but the prices would be outa wack

the linux version was a fresh install of ubuntu 20.04 lts with no updates or upgrades done prior to the start of this process

May the Pips be ever in your favor

Fred ( learning forex one pip at a time )
seeing how there is no way to edit what i posted above, it seems , ill post a correction , when i posted this part i copy and pasted it from the ref source sheet i made prior to doing the install, and in their verson they used version "261" and i used version "171" so if you copied each line and paste it into the terminal you would have gotten an error or the process would not know where the JAVA parts are.

So the correction is a change in the version release from "261" to "171" and should look like below, now keep in mind if you download a different version you just go through and change the version number in all the terminal commands done and edits in the gedit routine...

sudo update-alternatives --install "/usr/bin/java" "java" "/usr/lib/jvm/jdk1.8.0_171/bin/java" 0

sudo update-alternatives --install "/usr/bin/javac" "javac" "/usr/lib/jvm/jdk1.8.0_171/bin/javac" 0

sudo update-alternatives --set java /usr/lib/jvm/jdk1.8.0_171/bin/java

sudo update-alternatives --set javac /usr/lib/jvm/jdk1.8.0_171/bin/javac
FTMO Trader Scouting